Can't connect to Home Assistant - it tries to connect via HTTPS

home-assistant
release-beta6

#1

Hi all,
I have just installed Home Habit but when I’m trying to connect with my Home Assistant - I can’t.
Steps which I take:

  1. Run Home Habit
  2. Click Get Started
  3. Home Assistant
  4. Type: http://192.168.1.8:8123
  5. Click Continue
  6. Click CONNECT
  7. Here is what I get:

It looks like the app tries to connect via HTTPS, but my Home Assistant’s address is: http://192.168.1.8:8123
I don’t know why.
Please help, I would like to test Home Habits app but I just can’t.
Regards


#2

Thanks for reporting an issue!
This bug is fixed for the next patch release, that will be pushed out shortly.


#3

Ok, I will wait then.

In the meantime I configured SSL with Let’s encrypt. In browser Home Assistant is working but:

  1. Run Home Habit
  2. Click Get Started
  3. Home Assistant
  4. Type: https://mydomain.duckdns.org:8123
  5. Click Continue
  6. Click CONNECT
  7. Type my username and password
  8. Click NEXT
  9. And I’m back to screen like this:
  10. When again click CONNECT
  11. Type my username and password
  12. Click NEXT
  13. And I’m back to this screen again.

I can’t still connect with my Home Assistant. What I’m doing wrong?


#4

What is your device model and Android version?


#5

Tried on two devices:
Galaxy S8 - Android 8
Redmi Note 4 - Android 7.1.2


#6

@km4lin Please try again in the newest version (Beta 6.4). It might take several hours for it to reach Play Store.


#7

It works now! Thank you :smiley: