Home Assistant certificate problem (Android 7.1)

home-assistant

#1

Hi, I’m having problems with the ssl certificate.
I use a tablet with andorid 7.1
I also installed the application on my smartphone with andorid 9.0 and that’s fine!

PS: I apologize for the bad English

Thank you


Can't connect to Home Assistant - it tries to connect via HTTPS
#2

@Fabrizio_Martini Android 7.1 should have all new ciphers, so it is unclear why it’s not working.
What is the device brand/model? Also is it a self-signed certificate?


#3

The device is a samsung tab 3, I changed the operating system from androdi 4.4 to lineage os with andorid 7.1.2.
I configured duckdns with hassio so I think the ssl certificate is valid


#4

I have exactly the same problem, running on an old Nexus 7 tablet with Android 7.1.2 (crDroid). Once I close and open the app again it works again. Now it works for a day again, can’t reproduce the bug again.

EDIT:
Went trough my old log, the error I get in Home Assistant is:
Error doing job: SSL handshake failed
I get that error once in a few seconds when the connection fails. My SSL works like it should.


#5

I also have the same error in the hassio logs


#6

@Fabrizio_Martini/@SlipperyPickle there is a discussion thread on HA community that might be related to those fail logs, with no clear resolution short of installing nginx.
Does connection in the app fail when those error appear in the logs?


#7

When I try to connect from the app, the error appears in the hassio logs


#8

After error appears in the logs, does the app still work properly so you can control devices and widgets update correctly? or it actually disconnects from the server?


#9

When I have the error the app can’t connect to Home Assistant. Once I close the app completely and restart it, it will work again.


#10

Ok. It does seem to be specific to duckdns though, normally SSL either works or doesn’t, so this is a bit weird case. I will do more internal testing, see if I can reproduce it.


#11

ok thanks a lot, but there is a way to get around the ssl protocol?


#12

Not for remote connections. Bypassing ssl in that case is as bad as not using ssl at all.