Missing items - new setup

openhab

#1

I’ve just discovered homehabit after using rotini for a while. We’ve moved recently, so our HA setup is starting fresh. My current environment is a new install on OH2.5. I’m using the latest homehabit beta (beta 11 build 2135)

It’s great to see support for more platforms and UI config. However, I’m running into a bit of trouble on setup.

When I try to add widgets from UI, most (not all) of my openHAB items aren’t there. For example, if i try to add a dimmer widget, I go into bind item - the list is blank. However, a few items will appear if I add a switch widget. The behavior seems inconsistent for now, as sometimes more items will appear.

Is there something I’m overlooking on my item setup?

I’ve fallen back to text based config. Seems to be working well, but I just want to check, which method is recommended for setup now?

Thanks!


#2

@Roy_L Great to see that you have upgraded to new HomeHabit app!
In general, both UI and text-based config are supported equally, since there are variety of reasons why users prefer on over another. In addition, since config import/export is available, it is possible to switch from UI to text-base config and vice versa seamlessly.
Specifically in UI, when you bind an item, list of items shows whichever items are compatible with that widget property. For example, dimmer widget only shows dimmer items and contact items are not shown in switch widget.
If this is not consistent with what you expect to see in UI, please let me know, so we can investigate further.


#3

@igor Thanks so much for replying. I’ve mentioned this before, but rotini/homehabit is still the best mobile app I’ve used for HA. Keep up the great work.

Yes, I’ve tried two separate installs of OH2.5 (testing on windows, production on linux) and both times I was not able to get items to appear consistently in the “bind item” section. I’m thinking I must be doing something wrong? I tried different types of widgets including switches, dimmers, value.

The few times I was able to get items to appear, they seemed to be added through paperui autodiscovery. However, most of my items are configured in .items files.


#4

@Roy_L it shouldn’t matter if it is defined in items or auto-discovery, in fact, most of items in my personal setup are defined in .items files. Maybe something else is going on. Can you tell me what Android device and OS version are you using?


#5

Sure. I’m using a Galaxy S7 on Android 8 (oreo).

Right now, sensor items are showing, but switches, dimmers, and many others are not. I thought it might have been a proxy issue for remote connection, but it’s also happening on local connection.