Project Rotini Legacy


#1

Can you release a the legacy version with no timlimit please?
I have a old kindle running cyanogen mod that is a home controller; having to constantly update it is annoying.

I’d use the latest beta, but it doesn’t work on my LG G4 yet; nor does it work on my legacy tablet with cyanogenmod.

I just really need the legacy version as is for this old tablet.
Thanks

Rich


#2

I would love this as well. I would even pay for the legacy version as well as it still has features and pro’s over the current version. I am sure the current version will also get there and beyond eventually.

And I understand that without maintenance, the legacy version will stop working of something critical is changed in OpenHAB. But then it might be a choice to keep it running on an older version of OpenHAB as well.


#3

Legacy version is not intended to be available for long, so I would rather have people move over to the new version.
There are quite a few reasons why legacy version will need to be retired, and new version should be an almost complete and better replacement for it (even if few features are missing in the first release).

After further announcements on that, I will certainly address individual requests of keeping legacy version a bit longer, but everybody will need to be migrated eventually.

@milty456 I understand that you are waiting for phone support - it is one of the next updates

@Jeff Which particular features stop you from moving to the new version?


#4

Thanks…however it doesn’t work on my Kindle tablet running cyanogen either…legacy does…beta doesn’t even startup.


#5

@igor For me the biggest show-stopper is the lack a scene-selection (https://github.com/igorgladkov/rotini/wiki/Scene-Widget).
But I’ve seen them in your screenshots, so I suppose they will come eventually.

Same goes for the Mode widget (https://github.com/igorgladkov/rotini/wiki/Mode-Widget)

For that reason (and because I would like to do the config textual and I haven’t looked into in detail, also not a show-stopper but a con) I have not yet started to migrate my setup. Maybe I should, perhaps I find other show-stoppers (for my personal that is).


#6

@milty456 neither version officially supports cyanogen, so this is not something that was tested. I will check on this to see what could be done.


#7

@Jeff yes, both scene and mode widgets are coming in some form to the new version as well.
In terms of textual config, there is a preliminary support for that as well.
The UI would be the main configuration interface, but there are number of people who prefer text config, so it would be supported on par with UI-based config.


#8

Yes, I noticed, but then again, some widgets are not yet supported in textual form, such as sensors.
I think the main reason why people want a textual config is because of portability. If I put an interface at the front door and one at the bedroom, then I might like to have the same interface. An export/import would also work I suppose. A bit like the way HABpanel works?


#9

Could you please extend the legacy version. I’m sure plenty of us are still in the process of migration to the new version, but use the legacy version as a production version.
Thank you !


#10

@TRIROG extended release of the legacy version should be available in the Play Store as of few days ago. Do you not see the update?


#11

I still used the legacy version which now is gone from the playstore? Have a older setup on a pie 1 and openhab 1 which meets my requirements, the new app do not work on this setup. Any chance you could supply an old time user with the legacy, when it breaks down I’ll upgrade to openhab 2 and homehabbit


#12

Legacy version should still be available for updates on existing devices. Are you trying to install legacy version on a new device?

HomeHabit does support openhab v1 as well. Did you try to set it up and something wasn’t working?


#13

Hi thank you for the fast reply I have 2 units which say the same thing it can’t locate the update.
Regarding the update, the problem is not the homehabbit but my old rooted galaxy tab 2 which is not good friends with homehabbit.


#14

Which translated means item not found.


#15

That’s interesting. There is a possibility that because Google+ has gone away it cannot find the app even for existing users. It was working fine during our testing, but apparently not the case here.
Let me check what can be done here.


#16

@ChamDK can you send me direct message with email address for the google account used on those devices? I will manually add it to the list, I think it should work after about an hour or so.


#17

Done thanks


#18

added, please wait a bit and let me know whether it works or not.

Btw, thanks for posting about this, otherwise I wouldn’t know about the problem so quickly.
There are few other legacy users remaining, so I can post update if this works for you.


#19

I’ll do that, thanks for the quick assistence


#20

Can you fix that for me too? Thanks!