Ssl certificate


#1

Might be a good idea to add a way to skip ssl certificate warning.

Probably a lot of Home Assistant users like myself, use local IP to access the HA front end (on wifi), and since I have ssl certificate for duckdns domain mplemented, I get ssl warning and can’t start Rotini at all.


#2

From my understanding, duckdns HASS component should use Let’s Encrypt certificate, which should be a valid certificate, is it not?


#3

Yes it does and the certificate works just fine from outside my local network, but since my provider’s router does not support NAT loopback, I have to access HA from my IP address when at home (and not the duckdns address). And since my certificate is setup from https://xxx.duckdns.org it gives an error when accessed from https://192.168.1.xx.

It’s a pretty common issue and currently there are no workarounds (other then setting up some sort of DNSmasque server). In Chrome you can skip the warning but not in your app.

I hope I’m making sense here :slight_smile:


#4

Oh, got it. Will see what can be done about that.