A couple of suggestions for more convenient settings


#1

Creating a platform.

  1. When you enter the address (I use OpenHAB) local server, if the port is not specified, automatically use the default port (8080).
  2. When the keyboard opens, it overlaps the settings window on the tablet, it is very inconvenient, can you make the keyboard not overlap the settings?
  3. If you did not connect to the local server, then do not connect to the remote server. It would be good to be able to connect the platform without being in the same local network with it.

#2

We decided against defaulting to 8080 being that port 80 is default in browsers and it might be confusing otherwise. There are other possible improvement we can do there though.

Can you expand a bit on this, I’m not sure I completely understand the problem. Remote connection should be optional when creating a platform.


#3

It was about OpenHub2, whose default port is 8080 (this is just a sentence).

I apologize for my (google) english :slight_smile:
I will try again…
I have (for example) 2 lan.
I am now in lan1 and I need to connect the platform, as remote, from lan2.
But I can’t do this until I connect to the local server lan2.


#4

I vote for this point (GUI fix):

  1. When the keyboard opens, it overlaps the settings window on the tablet, it is very inconvenient, can you make the keyboard not overlap the settings?

#5

Follow up on the list:

The intent here is to follow behavior of a browser, which is where address would be usually entered.
Since all browsers universally default to port 80, it would be confusing to do anything different.
For example, for a setup that has openHAB on port 80 without entering a port, defaulting to 8080 would be highly unexpected.

This one is actually an Android bug with not good workaround.We will try to find some solution as soon as we can.

In the next release it will be possible to skip connection test for platform that has been already setup.