Dimmer widget is inconsistent and getting stuck with HA

release-beta3
home-assistant

#1

Having an issue with the dimmerfunction i belive.
I can add the dimmerwidget and when i change the value it also change the lightsbulbs intensity as wanted.
But as soon as I change the value on the dimmer from the widget itself I can not turn the light off again from within Rotini.
If I on the other hand turn the light on from HA, and from HA change the value I can still turn the light off from Rotini.
Rotini is also during this time updating the value of the brightness correctly.


Dimmer doesn't work with Home Assistant
#2

@Joesaar I’m a bit unclear on the problem. Let’s see if I got it correctly.
When you adjust dimmer from HA UI, it changes the light brightness and correctly updates Rotini UI. Is that correct?
When you adjust dimmer from Rotini UI, it doesn’t work and any subsequent changes don’t work either?


#3

When I adjust the dimmer from HA UI, it changes the light brightness and correctly updates Rotini UI.
I can then also turn off the light from both HA UI and Rotini UI.

If I adjust the light brightness on Rotini UI, it changes correctly but I can´t turn the light off from the rotini UI.
It blink a short second and then comes on again at the same settings.
I can turn the light off from HA UI.

If I then again turn the light on from Rotini UI I can then turn it off (as long as I don´t change the dimmer on Rotini UI)
And it also shows the correct new brightness setting.

So something seems to be missing when brightness is set from Rotini UI?


#4

Small update:
If I in Rotini UI set the dimmerwidget value to exactly 0,20,40,60,80,100 % it´s working.
I can then turn off the light from Rotini UI when adjusting the brightness to these values.
But using any other value from Rotini UI and it´s not working.
And since the slider goes by 1% at a time, its very hard to set it at those exact values.

Still able to turn the light off from HA all the time.


#5

@Joesaar do you still experience this issue with the latest version (Beta 2)?


#6

Hi, have installed beta2 and still having the same problems.
I have now tried to reinstall Rotini UI and added the HomeAssistant platform again.
But no success.

This is from todays experience:

  1. Light that uses MQTT and JSON to turn on/off is still the same, put the slider to 0,20,40,60,80% and the on/off button works.
  2. Light that uses a Nexa 433Mhz dimmer are not able to turn off at all, regardless of value in the dimmer.
  3. Light that uses a Fibaro Dimmer Z-wave start turning themselves on/off and all sorts of value on the dimmer until i restart my HA.
  4. Light that uses LifX Bulb and Wi-Fi is the same as my Fibaro, all crazy until i restart HA.

With No. 1 & 2 above I can still use the HA UI to turn them off/on again, but with no.3 & 4 the system got bananas on me and started turning them on and off without me being able to fix it with the HA UI.

Only thing working then was to restart the HA to get me back to square one.


#7

Now running the new beta3 version.
The new light function is working with most stuff now.

I now have in my setup a lightwidget with the on/off function and also a widget for the dimmer for one and the same lightsource.

  1. Dimmer and on/off function is working and updates correctly when on/off function and/or dimmer widget is used for the light (pulled down to 0, or raised to value)

  2. No problems, see no.1

  3. No problems, see no.1

  4. No Problems, see no.1 Also the LifX Wi-Fi lightbulb are working great with the new colorfunction in the lightwidget.

Everything is also updated correctly in Home Assistant.
Great work!


#8

That’s great to hear! Thanks for the update.